Car runs really crappy just read..... - Nissan 240SX Forums
S13 240SX (89-94) Technical Questions Specifically for ALL S13's. (Including 180SX's, 200SX's & Silvia's)

 
LinkBack Thread Tools
#1 Old 12-01-2004, 06:18 PM
 
Phenix's Avatar
 
Join Date: Nov 2003
Location: Atlanta
Age: 30
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
Phenix is on a distinguished road
(Thread Starter)
Car runs really crappy just read.....

Ok my car about 3 weeks ago started staling every single time i stoped. Weather it be a stop sign, red light or traffic. That was 3 weeks ago, i was told it was my MAF so i got a new one. Mine is a 91 240 and the one i was sent was a 95 240 MAF. When i got it, it didnt fit, so i made it fit. With duck tape and zip ties i got it done. When i took it for a drive to see if it worked the car wouldnt rev past 3,000 RPM. But the thing is the old MAF worked sometimes, it would sometimes not rev past 3,000 and it would just sputter. Sometimes the old one worked fine except for the fact it would stall out every time i stoped. But the new one wont even go past 3000 RPM at all. So if ANYONE knows what is wrong with my car plz tell me I need and want to get it fixed....THANX!

91 240sx 5spd nothing special yet.(i hate how things cost money)
Phenix is offline  
Sponsored Links
Advertisement
 
#2 Old 12-01-2004, 06:22 PM
 
Fidelity101's Avatar
 
Join Date: May 2004
Location: Chicagoland
Age: 27
Posts: 9,508
Blog Entries: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 94843768
Fidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthy
Points: 948,461,230, Level: 100
Points: 948,461,230, Level: 100 Points: 948,461,230, Level: 100 Points: 948,461,230, Level: 100
Activity: 13%
Activity: 13% Activity: 13% Activity: 13%
Do you have a new ECU?

thats been known to happen if you put in an auto ECU for a manual.
Fidelity101 is offline  
#3 Old 12-01-2004, 06:23 PM
 
musicmaniac's Avatar
 
Join Date: Jun 2004
Age: 29
Posts: 385
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 756
musicmaniac is on a distinguished road
Points: 4,746, Level: 43
Points: 4,746, Level: 43 Points: 4,746, Level: 43 Points: 4,746, Level: 43
Activity: 1%
Activity: 1% Activity: 1% Activity: 1%
fuel pump?

dohc swap, 91+ front end, ractive seat and 4 pt harnesses ( 200 bucks brand new i couldnt resist), centerforce stage 2 clutch, need some susp work
musicmaniac is offline  
#4 Old 12-01-2004, 06:25 PM
 
Phenix's Avatar
 
Join Date: Nov 2003
Location: Atlanta
Age: 30
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
Phenix is on a distinguished road
(Thread Starter)
I have manual ECU and as far i know its ok, Fuel pump i have no idea, ill take a look at it.

91 240sx 5spd nothing special yet.(i hate how things cost money)
Phenix is offline  
#5 Old 12-01-2004, 06:35 PM
 
Shwag's Avatar
 
Join Date: Jun 2004
Location: Lakewood, NJ
Age: 28
Posts: 5,132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 10378120
Shwag The posts made by this user are trust worthyShwag The posts made by this user are trust worthyShwag The posts made by this user are trust worthyShwag The posts made by this user are trust worthyShwag The posts made by this user are trust worthyShwag The posts made by this user are trust worthyShwag The posts made by this user are trust worthyShwag The posts made by this user are trust worthyShwag The posts made by this user are trust worthyShwag The posts made by this user are trust worthyShwag The posts made by this user are trust worthy
Points: 103,789,393, Level: 100
Points: 103,789,393, Level: 100 Points: 103,789,393, Level: 100 Points: 103,789,393, Level: 100
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
The problem wasn't with the maf, its because things got dirty.
Clean out the throttle body with carb cleaner and clean/replace all the vaccuum lines.
Jesus, thats the first thing I read on this forum like 6 months ago, how everyone has problems with the engine stalling when you come to a stop.

Quote:
Originally Posted by Johann Wolfgang von Goethe
None are more hopelessly enslaved than those who falsely believe they are free.
Shwag is offline  
#6 Old 12-01-2004, 09:33 PM
 
Phenix's Avatar
 
Join Date: Nov 2003
Location: Atlanta
Age: 30
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
Phenix is on a distinguished road
(Thread Starter)
The throttle body is clean i clean it myslef like twice a week. The vaccuum lines i will look into. Thanx for all your feedback.

91 240sx 5spd nothing special yet.(i hate how things cost money)
Phenix is offline  
#7 Old 12-02-2004, 02:34 AM
 
ShadyCajun's Avatar
 
Join Date: Oct 2002
Location: Louisiana
Age: 32
Posts: 553
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 880
ShadyCajun is on a distinguished road
Quote:
Originally Posted by Shwag
Jesus, thats the first thing I read on this forum like 6 months ago, how everyone has problems with the engine stalling when you come to a stop.
Yeah, I think everyone has had that problem at one time or another (or WILL). There are a few things it could be though, not always just vacuum lines, etc.

I had the same problem when I joined the forum a few years ago, and after inspecting every vacuum line I could find, I did find a couple hoses that needed changing...helped the problem, but didn't fix it. It's not till it died an hour and a half away from home that I finally figured out it was the fuel pump. So these symptoms could very well be a dying fuel pump as musicmaniac suggested. Thankfully if it is, it's a VERY VERY simple affair to pop in a new (or working used) pump.
ShadyCajun is offline  
#8 Old 12-02-2004, 10:02 AM
 
Join Date: Nov 2004
Age: 30
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
Luv2Drift is on a distinguished road
Points: 4,243, Level: 41
Points: 4,243, Level: 41 Points: 4,243, Level: 41 Points: 4,243, Level: 41
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
fuel pump..

Luv2Drift is offline  
#9 Old 12-02-2004, 10:14 AM
 
RPS13DRFTR's Avatar
 
Join Date: Aug 2004
Location: Florida
Age: 31
Posts: 151
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 739
RPS13DRFTR is on a distinguished road
Points: 5,261, Level: 46
Points: 5,261, Level: 46 Points: 5,261, Level: 46 Points: 5,261, Level: 46
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Sounds to me like a combination of 2 problems. IAC valve and fuel pump. IAC valve is causing you to stall at stops, and the fuel pump will not allow you to go into the higher rpm's. Once your fuel pump loses effeciency, it doesn't supply the needed pressure, thus in higher rpm's when more fuel is demanded it can't deliver due to lack of psi and leans out to the point of spitting and sputtering. The same thing happened to me dude, I just went to the junk yard and got another fuel pump outof an S14 and now it's a beast compared to the power it had b4 I replaced the pump.
Your motor is just chokin for fuel dude, and needs a new IAC valve.

Automotive Performance......My Antidrug

SHIFT_Bliss

Speed bumps suck
RPS13DRFTR is offline  
#10 Old 12-02-2004, 10:24 AM
 
Fidelity101's Avatar
 
Join Date: May 2004
Location: Chicagoland
Age: 27
Posts: 9,508
Blog Entries: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 94843768
Fidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthyFidelity101 The posts made by this user are trust worthy
Points: 948,461,230, Level: 100
Points: 948,461,230, Level: 100 Points: 948,461,230, Level: 100 Points: 948,461,230, Level: 100
Activity: 13%
Activity: 13% Activity: 13% Activity: 13%
I had a similar problem like that a few weeks ago, it would stall on a rare occasion when I would engine brake.

but are you running rich already?

because this was happening to me while I was running rich, until I blew my 2nd piston injector, but got that fixed and now no richness and no stall during engine brake.

because it was running rich and putting brake on the gas, I was putting to much force on it so it died, or something like that, but that wouldn't explain the not being able to rev past 3kprm.
Fidelity101 is offline  
#11 Old 12-03-2004, 12:47 AM
 
Join Date: Sep 2003
Location: texas
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
eliterit is on a distinguished road
i had the same problem happen to me on my 93 se-r

it's a n/a sr20 but it turned out to be that the ground wire on my maf just needed to be regrounded
eliterit is offline  
#12 Old 12-03-2004, 01:49 AM
 
Join Date: May 2004
Location: Monterey Park, CA (also Westwood)
Age: 29
Posts: 84
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 761
aznyo15 is on a distinguished road
Quote:
Originally Posted by Fidelity101
Do you have a new ECU?

thats been known to happen if you put in an auto ECU for a manual.
Aren't the ecu's for the 91 auto and manual perfectly interchangable? I always thought they were basically the same unit except for the 5th gear sensor and fuel cut.
aznyo15 is offline  
#13 Old 12-03-2004, 01:55 AM
 
Join Date: Sep 2003
Location: San Diego
Age: 30
Posts: 138
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 807
bouncin_180 is on a distinguished road
Points: 4,632, Level: 43
Points: 4,632, Level: 43 Points: 4,632, Level: 43 Points: 4,632, Level: 43
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
how about this ... when u got the 95 maf did it come wit a plug also? if not did u use yer old one? cause ya from what ive seen n heard the plugs aren't the same so ya. u should just got another 91-93 maf
bouncin_180 is offline  
#14 Old 12-03-2004, 11:09 AM
 
RPS13DRFTR's Avatar
 
Join Date: Aug 2004
Location: Florida
Age: 31
Posts: 151
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 739
RPS13DRFTR is on a distinguished road
Points: 5,261, Level: 46
Points: 5,261, Level: 46 Points: 5,261, Level: 46 Points: 5,261, Level: 46
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Quote:
Originally Posted by bouncin_180
how about this ... when u got the 95 maf did it come wit a plug also? if not did u use yer old one? cause ya from what ive seen n heard the plugs aren't the same so ya. u should just got another 91-93 maf
Yeah they shouldn't be the same cause even though they might be the same motor, they have different engine managements....(obd-ll)....err whatever the hell you call it.

Automotive Performance......My Antidrug

SHIFT_Bliss

Speed bumps suck
RPS13DRFTR is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan 240SX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome