sr20det sputtering when boosting - Nissan 240SX Forums
SR20DE & DET Tech Section for all things SR. (Including the N/A SR20DE)

 
LinkBack Thread Tools
#1 Old 05-29-2011, 05:34 PM
 
Join Date: Jul 2010
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
(Thread Starter)
sr20det sputtering when boosting

my s13 sr redtop has been sputtering when i boost and feels like it hits a rev limiter when i step on it. but if i just give it half throttle it will go just fine but when i make the turbo spool it sputters. I cleaned the MAF with crc maf cleaner, put BCPR&ES NGK plugs and gapped them to 28, took off IACV and sprayed it out with carb and choke cleaner, put new 300zx fuel filter and also added a bottle of techron fuel system cleaner...I was running about 12psi on stock maf, injectors, and t25. now it wont boost past 9psi. Also i can air coming from the MBC when the car is idling. I have a HKS ssqv BOV that is ATM not recirculated could that have anything to do with it?

PLEASE PLEASE help!!!

EDIT: I have a walbro 255 fuel pump and FMIC
davidg01234 is offline  
Sponsored Links
Advertisement
 
#2 Old 05-29-2011, 06:11 PM
 
SRvertS13's Avatar
 
Join Date: Mar 2011
Location: Allentown
Age: 23
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
SRvertS13 is on a distinguished road
Points: 279, Level: 5
Points: 279, Level: 5 Points: 279, Level: 5 Points: 279, Level: 5
Activity: 1%
Activity: 1% Activity: 1% Activity: 1%
I am looking for help for the same problem with my black top. do the rpms drop when you come to stops? mine almost stalls sometimes. i was told i need to recirculate my hks bov, but i think ill try some of the things you did first.

I also have a 255 walbro
SRvertS13 is offline  
#3 Old 05-29-2011, 06:14 PM
 
SRvertS13's Avatar
 
Join Date: Mar 2011
Location: Allentown
Age: 23
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
SRvertS13 is on a distinguished road
Points: 279, Level: 5
Points: 279, Level: 5 Points: 279, Level: 5 Points: 279, Level: 5
Activity: 1%
Activity: 1% Activity: 1% Activity: 1%
i also can hear my bov leaking when i hit about 3k, the motor starts bogging at 35k.
SRvertS13 is offline  
#4 Old 05-29-2011, 07:47 PM
 
Join Date: Jul 2010
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
(Thread Starter)
Quote:
Originally Posted by SRvertS13 Last Post
I am looking for help for the same problem with my black top. do the rpms drop when you come to stops? mine almost stalls sometimes. i was told i need to recirculate my hks bov, but i think ill try some of the things you did first.

I also have a 255 walbro
yes mine does that too and yes it is because the BOV i already ordered a recirculation insert for mine
davidg01234 is offline  
#5 Old 05-29-2011, 10:05 PM
Cap'n Slow
 
RikRong's Avatar
 
Join Date: May 2010
Location: ND
Age: 34
Posts: 4,963
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 214748729
RikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthy
Points: 2,147,499,449, Level: 100
Points: 2,147,499,449, Level: 100 Points: 2,147,499,449, Level: 100 Points: 2,147,499,449, Level: 100
Activity: 8%
Activity: 8% Activity: 8% Activity: 8%
As for the spark plugs, I always ran BKR6EIX-7 or 8 in my two SR's. However, I think the spark plugs you have are okay, they're just the none iridium NGKs and meant for the SR. The other symptoms you are talking about, sputtering under boost, sounds like fuel cut. Do you have any kind of tune? The FMIC and boost controller might be enough to overload the ECU.


R. Long
Manuals > USDM Cars > 1991-1994 240SX (KA24DE) - Nissan 240SX Performance Tuning
Quote:
Originally Posted by 4x4le Last Post
yea, only it is meant to make the undead dead again
RikRong is offline  
#6 Old 05-29-2011, 11:18 PM
 
SRvertS13's Avatar
 
Join Date: Mar 2011
Location: Allentown
Age: 23
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
SRvertS13 is on a distinguished road
Points: 279, Level: 5
Points: 279, Level: 5 Points: 279, Level: 5 Points: 279, Level: 5
Activity: 1%
Activity: 1% Activity: 1% Activity: 1%
i found a kink in my fuel line right before the filter and it ran a lot better after i fixed it. still bogs though, im going to try the recirculation for the bov and see how it works out. thanks guys.
SRvertS13 is offline  
#7 Old 05-29-2011, 11:23 PM
 
Join Date: Jul 2010
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
(Thread Starter)
Quote:
Originally Posted by RikRong Last Post
As for the spark plugs, I always ran BKR6EIX-7 or 8 in my two SR's. However, I think the spark plugs you have are okay, they're just the none iridium NGKs and meant for the SR. The other symptoms you are talking about, sputtering under boost, sounds like fuel cut. Do you have any kind of tune? The FMIC and boost controller might be enough to overload the ECU.
No I don't have any tune but I do have an apexi neo on the way. But either way I NEVER had this problem
davidg01234 is offline  
#8 Old 05-29-2011, 11:26 PM
 
Join Date: Jul 2010
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
(Thread Starter)
Quote:
Originally Posted by SRvertS13 Last Post
i found a kink in my fuel line right before the filter and it ran a lot better after i fixed it. still bogs though, im going to try the recirculation for the bov and see how it works out. thanks guys.
yup

MAF + non circulated bov= problems. I can't wait for mine to come in
davidg01234 is offline  
#9 Old 05-30-2011, 09:55 AM
 
Join Date: Jul 2010
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
(Thread Starter)
Anybody else have any idea?
davidg01234 is offline  
#10 Old 05-30-2011, 10:39 AM
 
SRvertS13's Avatar
 
Join Date: Mar 2011
Location: Allentown
Age: 23
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
SRvertS13 is on a distinguished road
Points: 279, Level: 5
Points: 279, Level: 5 Points: 279, Level: 5 Points: 279, Level: 5
Activity: 1%
Activity: 1% Activity: 1% Activity: 1%
anybody have any pics of what a recirculation kit should look like on an sr20det? i was thinking about making a homemade one for now, bad idea?
SRvertS13 is offline  
#11 Old 05-30-2011, 10:45 AM
 
Join Date: Jul 2010
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
(Thread Starter)
Just buy one. Its only about 20 bucks
davidg01234 is offline  
#12 Old 05-30-2011, 10:52 AM
 
Join Date: Jul 2010
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
(Thread Starter)
All you gotta do is take a hose and run it from your bov and back into the turbo inlet pipe.
davidg01234 is offline  
#13 Old 05-30-2011, 01:47 PM
 
Join Date: Aug 2007
Location: Nazareth, Pa
Age: 29
Posts: 401
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 519
champ_6 is on a distinguished road
Points: 6,708, Level: 53
Points: 6,708, Level: 53 Points: 6,708, Level: 53 Points: 6,708, Level: 53
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
The HKS should not be leaking under boost even if it's not recirculated. Do a boost leak test.
champ_6 is offline  
#14 Old 05-30-2011, 05:33 PM
 
Join Date: Jul 2010
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
(Thread Starter)
[QUOTE=champ_6;1634484]The HKS should not be leaking under boost even if it's not recirculated. Do a boost leak test.[/QU

Its not leaking? my turbo xs MBC is leaking when idling. but like i said MAF + ATM BOV will make it not run as it should because the maf can compensate for all the lost air that the bov releases

Also does anybody have a link or a good way to do a DIY boost leak test
davidg01234 is offline  
#15 Old 05-30-2011, 05:36 PM
 
Join Date: Aug 2007
Location: Nazareth, Pa
Age: 29
Posts: 401
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 519
champ_6 is on a distinguished road
Points: 6,708, Level: 53
Points: 6,708, Level: 53 Points: 6,708, Level: 53 Points: 6,708, Level: 53
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
Quote:
Originally Posted by davidg01234 Last Post
Quote:
Originally Posted by champ_6 Last Post
The HKS should not be leaking under boost even if it's not recirculated. Do a boost leak test.
Its not leaking? my turbo xs MBC is leaking when idling. but like i said MAF + ATM BOV will make it not run as it should because the maf can compensate for all the lost air that the bov releases

Also does anybody have a link or a good way to do a DIY boost leak test
Take the MBC out and see if your problem goes away. Yes the ATM BOV will cause it go rich for a moment while shifting but it will not cause the car to break up under full throttle
champ_6 is offline  
#16 Old 05-30-2011, 05:42 PM
 
Join Date: Aug 2007
Location: Nazareth, Pa
Age: 29
Posts: 401
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 519
champ_6 is on a distinguished road
Points: 6,708, Level: 53
Points: 6,708, Level: 53 Points: 6,708, Level: 53 Points: 6,708, Level: 53
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
Quote:
Originally Posted by davidg01234 Last Post
Quote:
Originally Posted by champ_6 Last Post
The HKS should not be leaking under boost even if it's not recirculated. Do a boost leak test.
Its not leaking? my turbo xs MBC is leaking when idling. but like i said MAF + ATM BOV will make it not run as it should because the maf can compensate for all the lost air that the bov releases

Also does anybody have a link or a good way to do a DIY boost leak test
IC Pipe Tester
champ_6 is offline  
#17 Old 05-30-2011, 05:47 PM
 
Join Date: Jul 2010
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
(Thread Starter)
awesome thanks. also do you know if its normal to be able to hear air coming from the mbc when the car is just idling? If i turn the screw all the way in it wont do it but when i turn it out to turn up the boost i can hear it leaking at idle
davidg01234 is offline  
#18 Old 05-30-2011, 05:51 PM
 
Join Date: Aug 2007
Location: Nazareth, Pa
Age: 29
Posts: 401
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 519
champ_6 is on a distinguished road
Points: 6,708, Level: 53
Points: 6,708, Level: 53 Points: 6,708, Level: 53 Points: 6,708, Level: 53
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
Quote:
Originally Posted by davidg01234 Last Post
awesome thanks. also do you know if its normal to be able to hear air coming from the mbc when the car is just idling? If i turn the screw all the way in it wont do it but when i turn it out to turn up the boost i can hear it leaking at idle
Can't say that I've ever heard air at idle. Spray it with starting fluid and see if your engine revs up. If it does then you have a leak there
champ_6 is offline  
#19 Old 05-30-2011, 05:55 PM
 
Join Date: Jul 2010
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
(Thread Starter)
ok ill give that a shot after i go to home depot to make my boost leak tester lol thanks
davidg01234 is offline  
#20 Old 06-06-2011, 01:28 PM
 
Join Date: Jun 2011
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
srs13lemy is on a distinguished road
Points: 108, Level: 2
Points: 108, Level: 2 Points: 108, Level: 2 Points: 108, Level: 2
Activity: 10%
Activity: 10% Activity: 10% Activity: 10%
iv been having the same issue with my sr.. i did a test on mine found 3 different leaks. the home depot leack tester works grate.

on mine: mbc, bov flange, and turbo hose are leaking. i get that stuttering when im coming to a stop but not at wot. my wot is good...
srs13lemy is offline  
#21 Old 06-06-2011, 03:02 PM
 
driftsyndicate's Avatar
 
Join Date: Apr 2009
Posts: 70
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 0
driftsyndicate is on a distinguished road
Points: 2,690, Level: 31
Points: 2,690, Level: 31 Points: 2,690, Level: 31 Points: 2,690, Level: 31
Activity: 6%
Activity: 6% Activity: 6% Activity: 6%
leaking coupler

use hairspray on any leaky couplers
werks great
driftsyndicate is offline  
#22 Old 06-06-2011, 03:51 PM
 
SilverS13's Avatar
 
Join Date: Jun 2008
Posts: 309
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Rep Power: 455
SilverS13 is on a distinguished road
Points: 5,100, Level: 45
Points: 5,100, Level: 45 Points: 5,100, Level: 45 Points: 5,100, Level: 45
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
Do you have a boost gauge? How much boost are you running? If you don't have one you can't tell how much boost you are running and you might be running too much causing boost cut. Check all vaccum lines and the the intercooler connections to make sure its not leaking from anywhere. When I first put on my s14 turbo the damn intercooler pipe blew off at only 10psi, I had to use T-clamps. Oh yeah one more thing, when was the last time the car had a tune up? One of these is bound to be the problem.
SilverS13 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan 240SX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome