sr20det sputtering when boosting - Nissan 240SX Forums
 

Please visit this 240SX forums sponsor!
Go Back   Nissan 240SX Forums > Nissan 240SX Technical Section > SR20DE & DET
Connect with Facebook


SR20DE & DET Tech Section for all things SR. (Including the N/A SR20DE)

240SXForums.com is the premier Nissan 240sx Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 05-29-2011, 05:34 PM   #1 (permalink)
 

Join Date: Jul 2010
Posts: 129
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
sr20det sputtering when boosting

my s13 sr redtop has been sputtering when i boost and feels like it hits a rev limiter when i step on it. but if i just give it half throttle it will go just fine but when i make the turbo spool it sputters. I cleaned the MAF with crc maf cleaner, put BCPR&ES NGK plugs and gapped them to 28, took off IACV and sprayed it out with carb and choke cleaner, put new 300zx fuel filter and also added a bottle of techron fuel system cleaner...I was running about 12psi on stock maf, injectors, and t25. now it wont boost past 9psi. Also i can air coming from the MBC when the car is idling. I have a HKS ssqv BOV that is ATM not recirculated could that have anything to do with it?

PLEASE PLEASE help!!!

EDIT: I have a walbro 255 fuel pump and FMIC
davidg01234 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-29-2011, 06:11 PM   #2 (permalink)
 
SRvertS13's Avatar
 

Join Date: Mar 2011
Location: Allentown
Age: 22
Posts: 17
Rep Power: 0
SRvertS13 is on a distinguished road
Points: 279, Level: 5
Points: 279, Level: 5 Points: 279, Level: 5 Points: 279, Level: 5
Activity: 1%
Activity: 1% Activity: 1% Activity: 1%
I am looking for help for the same problem with my black top. do the rpms drop when you come to stops? mine almost stalls sometimes. i was told i need to recirculate my hks bov, but i think ill try some of the things you did first.

I also have a 255 walbro
SRvertS13 is offline   Reply With Quote Quick reply to this message
Old 05-29-2011, 06:14 PM   #3 (permalink)
 
SRvertS13's Avatar
 

Join Date: Mar 2011
Location: Allentown
Age: 22
Posts: 17
Rep Power: 0
SRvertS13 is on a distinguished road
Points: 279, Level: 5
Points: 279, Level: 5 Points: 279, Level: 5 Points: 279, Level: 5
Activity: 1%
Activity: 1% Activity: 1% Activity: 1%
i also can hear my bov leaking when i hit about 3k, the motor starts bogging at 35k.
SRvertS13 is offline   Reply With Quote Quick reply to this message
Old 05-29-2011, 07:47 PM   #4 (permalink)
 

Join Date: Jul 2010
Posts: 129
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
Quote:
Originally Posted by SRvertS13 View Post
I am looking for help for the same problem with my black top. do the rpms drop when you come to stops? mine almost stalls sometimes. i was told i need to recirculate my hks bov, but i think ill try some of the things you did first.

I also have a 255 walbro
yes mine does that too and yes it is because the BOV i already ordered a recirculation insert for mine
davidg01234 is offline   Reply With Quote Quick reply to this message
Old 05-29-2011, 10:05 PM   #5 (permalink)
Cap'n Slow
 
RikRong's Avatar
 

Join Date: May 2010
Location: ND
Age: 34
Posts: 4,941
Rep Power: 214748703
RikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthyRikRong The posts made by this user are trust worthy
Points: 2,147,499,035, Level: 100
Points: 2,147,499,035, Level: 100 Points: 2,147,499,035, Level: 100 Points: 2,147,499,035, Level: 100
Activity: 33%
Activity: 33% Activity: 33% Activity: 33%
As for the spark plugs, I always ran BKR6EIX-7 or 8 in my two SR's. However, I think the spark plugs you have are okay, they're just the none iridium NGKs and meant for the SR. The other symptoms you are talking about, sputtering under boost, sounds like fuel cut. Do you have any kind of tune? The FMIC and boost controller might be enough to overload the ECU.
__________________

R. Long
Manuals > USDM Cars > 1991-1994 240SX (KA24DE) - Nissan 240SX Performance Tuning
Quote:
Originally Posted by 4x4le View Post
yea, only it is meant to make the undead dead again
RikRong is offline   Reply With Quote Quick reply to this message
Old 05-29-2011, 11:18 PM   #6 (permalink)
 
SRvertS13's Avatar
 

Join Date: Mar 2011
Location: Allentown
Age: 22
Posts: 17
Rep Power: 0
SRvertS13 is on a distinguished road
Points: 279, Level: 5
Points: 279, Level: 5 Points: 279, Level: 5 Points: 279, Level: 5
Activity: 1%
Activity: 1% Activity: 1% Activity: 1%
i found a kink in my fuel line right before the filter and it ran a lot better after i fixed it. still bogs though, im going to try the recirculation for the bov and see how it works out. thanks guys.
SRvertS13 is offline   Reply With Quote Quick reply to this message
Old 05-29-2011, 11:23 PM   #7 (permalink)
 

Join Date: Jul 2010
Posts: 129
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
Quote:
Originally Posted by RikRong View Post
As for the spark plugs, I always ran BKR6EIX-7 or 8 in my two SR's. However, I think the spark plugs you have are okay, they're just the none iridium NGKs and meant for the SR. The other symptoms you are talking about, sputtering under boost, sounds like fuel cut. Do you have any kind of tune? The FMIC and boost controller might be enough to overload the ECU.
No I don't have any tune but I do have an apexi neo on the way. But either way I NEVER had this problem
davidg01234 is offline   Reply With Quote Quick reply to this message
Old 05-29-2011, 11:26 PM   #8 (permalink)
 

Join Date: Jul 2010
Posts: 129
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
Quote:
Originally Posted by SRvertS13 View Post
i found a kink in my fuel line right before the filter and it ran a lot better after i fixed it. still bogs though, im going to try the recirculation for the bov and see how it works out. thanks guys.
yup

MAF + non circulated bov= problems. I can't wait for mine to come in
davidg01234 is offline   Reply With Quote Quick reply to this message
Old 05-30-2011, 09:55 AM   #9 (permalink)
 

Join Date: Jul 2010
Posts: 129
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
Anybody else have any idea?
davidg01234 is offline   Reply With Quote Quick reply to this message
Old 05-30-2011, 10:39 AM   #10 (permalink)
 
SRvertS13's Avatar
 

Join Date: Mar 2011
Location: Allentown
Age: 22
Posts: 17
Rep Power: 0
SRvertS13 is on a distinguished road
Points: 279, Level: 5
Points: 279, Level: 5 Points: 279, Level: 5 Points: 279, Level: 5
Activity: 1%
Activity: 1% Activity: 1% Activity: 1%
anybody have any pics of what a recirculation kit should look like on an sr20det? i was thinking about making a homemade one for now, bad idea?
SRvertS13 is offline   Reply With Quote Quick reply to this message
Old 05-30-2011, 10:45 AM   #11 (permalink)
 

Join Date: Jul 2010
Posts: 129
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
Just buy one. Its only about 20 bucks
davidg01234 is offline   Reply With Quote Quick reply to this message
Old 05-30-2011, 10:52 AM   #12 (permalink)
 

Join Date: Jul 2010
Posts: 129
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
All you gotta do is take a hose and run it from your bov and back into the turbo inlet pipe.
davidg01234 is offline   Reply With Quote Quick reply to this message
Old 05-30-2011, 01:47 PM   #13 (permalink)
 

Join Date: Aug 2007
Location: Nazareth, Pa
Age: 29
Posts: 400
Rep Power: 493
champ_6 is on a distinguished road
Points: 6,147, Level: 50
Points: 6,147, Level: 50 Points: 6,147, Level: 50 Points: 6,147, Level: 50
Activity: 17%
Activity: 17% Activity: 17% Activity: 17%
The HKS should not be leaking under boost even if it's not recirculated. Do a boost leak test.
champ_6 is offline   Reply With Quote Quick reply to this message
Old 05-30-2011, 05:33 PM   #14 (permalink)
 

Join Date: Jul 2010
Posts: 129
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
[QUOTE=champ_6;1634484]The HKS should not be leaking under boost even if it's not recirculated. Do a boost leak test.[/QU

Its not leaking? my turbo xs MBC is leaking when idling. but like i said MAF + ATM BOV will make it not run as it should because the maf can compensate for all the lost air that the bov releases

Also does anybody have a link or a good way to do a DIY boost leak test
davidg01234 is offline   Reply With Quote Quick reply to this message
Old 05-30-2011, 05:36 PM   #15 (permalink)
 

Join Date: Aug 2007
Location: Nazareth, Pa
Age: 29
Posts: 400
Rep Power: 493
champ_6 is on a distinguished road
Points: 6,147, Level: 50
Points: 6,147, Level: 50 Points: 6,147, Level: 50 Points: 6,147, Level: 50
Activity: 17%
Activity: 17% Activity: 17% Activity: 17%
Quote:
Originally Posted by davidg01234 View Post
Quote:
Originally Posted by champ_6 View Post
The HKS should not be leaking under boost even if it's not recirculated. Do a boost leak test.
Its not leaking? my turbo xs MBC is leaking when idling. but like i said MAF + ATM BOV will make it not run as it should because the maf can compensate for all the lost air that the bov releases

Also does anybody have a link or a good way to do a DIY boost leak test
Take the MBC out and see if your problem goes away. Yes the ATM BOV will cause it go rich for a moment while shifting but it will not cause the car to break up under full throttle
champ_6 is offline   Reply With Quote Quick reply to this message
Old 05-30-2011, 05:42 PM   #16 (permalink)
 

Join Date: Aug 2007
Location: Nazareth, Pa
Age: 29
Posts: 400
Rep Power: 493
champ_6 is on a distinguished road
Points: 6,147, Level: 50
Points: 6,147, Level: 50 Points: 6,147, Level: 50 Points: 6,147, Level: 50
Activity: 17%
Activity: 17% Activity: 17% Activity: 17%
Quote:
Originally Posted by davidg01234 View Post
Quote:
Originally Posted by champ_6 View Post
The HKS should not be leaking under boost even if it's not recirculated. Do a boost leak test.
Its not leaking? my turbo xs MBC is leaking when idling. but like i said MAF + ATM BOV will make it not run as it should because the maf can compensate for all the lost air that the bov releases

Also does anybody have a link or a good way to do a DIY boost leak test
IC Pipe Tester
champ_6 is offline   Reply With Quote Quick reply to this message
Old 05-30-2011, 05:47 PM   #17 (permalink)
 

Join Date: Jul 2010
Posts: 129
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
awesome thanks. also do you know if its normal to be able to hear air coming from the mbc when the car is just idling? If i turn the screw all the way in it wont do it but when i turn it out to turn up the boost i can hear it leaking at idle
davidg01234 is offline   Reply With Quote Quick reply to this message
Old 05-30-2011, 05:51 PM   #18 (permalink)
 

Join Date: Aug 2007
Location: Nazareth, Pa
Age: 29
Posts: 400
Rep Power: 493
champ_6 is on a distinguished road
Points: 6,147, Level: 50
Points: 6,147, Level: 50 Points: 6,147, Level: 50 Points: 6,147, Level: 50
Activity: 17%
Activity: 17% Activity: 17% Activity: 17%
Quote:
Originally Posted by davidg01234 View Post
awesome thanks. also do you know if its normal to be able to hear air coming from the mbc when the car is just idling? If i turn the screw all the way in it wont do it but when i turn it out to turn up the boost i can hear it leaking at idle
Can't say that I've ever heard air at idle. Spray it with starting fluid and see if your engine revs up. If it does then you have a leak there
champ_6 is offline   Reply With Quote Quick reply to this message
Old 05-30-2011, 05:55 PM   #19 (permalink)
 

Join Date: Jul 2010
Posts: 129
Rep Power: 0
davidg01234 is on a distinguished road
Points: 1,759, Level: 24
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
ok ill give that a shot after i go to home depot to make my boost leak tester lol thanks
davidg01234 is offline   Reply With Quote Quick reply to this message
Old 06-06-2011, 01:28 PM   #20 (permalink)
 

Join Date: Jun 2011
Posts: 20
Rep Power: 0
srs13lemy is on a distinguished road
Points: 108, Level: 2
Points: 108, Level: 2 Points: 108, Level: 2 Points: 108, Level: 2
Activity: 10%
Activity: 10% Activity: 10% Activity: 10%
iv been having the same issue with my sr.. i did a test on mine found 3 different leaks. the home depot leack tester works grate.

on mine: mbc, bov flange, and turbo hose are leaking. i get that stuttering when im coming to a stop but not at wot. my wot is good...
srs13lemy is offline   Reply With Quote Quick reply to this message
Old 06-06-2011, 03:02 PM   #21 (permalink)
 
driftsyndicate's Avatar
 

Join Date: Apr 2009
Posts: 70
Rep Power: 0
driftsyndicate is on a distinguished road
Points: 2,690, Level: 31
Points: 2,690, Level: 31 Points: 2,690, Level: 31 Points: 2,690, Level: 31
Activity: 6%
Activity: 6% Activity: 6% Activity: 6%
leaking coupler

use hairspray on any leaky couplers
werks great
driftsyndicate is offline   Reply With Quote Quick reply to this message
Old 06-06-2011, 03:51 PM   #22 (permalink)
 
SilverS13's Avatar
 

Join Date: Jun 2008
Posts: 309
Rep Power: 429
SilverS13 is on a distinguished road
Points: 5,100, Level: 45
Points: 5,100, Level: 45 Points: 5,100, Level: 45 Points: 5,100, Level: 45
Activity: 3%
Activity: 3% Activity: 3% Activity: 3%
Do you have a boost gauge? How much boost are you running? If you don't have one you can't tell how much boost you are running and you might be running too much causing boost cut. Check all vaccum lines and the the intercooler connections to make sure its not leaking from anywhere. When I first put on my s14 turbo the damn intercooler pipe blew off at only 10psi, I had to use T-clamps. Oh yeah one more thing, when was the last time the car had a tune up? One of these is bound to be the problem.
SilverS13 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan 240SX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boosting up my sr20det ??? Blaze89 General Tech 3 03-31-2010 11:19 AM
sr20det only boosting 6psi all of sudden...... -darren- SR20DE & DET 3 03-23-2006 11:47 AM
sr20det sputtering - vacum leak ? o2 sensor ? Twistex SR20DE & DET 3 02-10-2005 03:16 AM
Car Sputtering, Need Help r34silvia S13 240SX (89-94) 8 06-23-2004 11:57 PM
sr20det not boosting igotswansons SR20DE & DET 3 08-20-2003 04:58 PM



Nissan 240SX Forums Home Index - Nissan Juke - Nissan For Sale - Archive - Privacy Statement
240SXforums.com is in no way affiliated with Nissan Motors Co, Ltd.
All Trademarks are property of their respective owners. 240SXforums.com is an enthusiast community for the Nissan 240SX (Silvia).


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.2.0