Nissan 240SX Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hey i just picked up a 95, it ran fine but now it stalls and stumbles. no codes. im just looking for any common problems or things to look for before i start diagnosing it. thanks.

it runs fine under load
but surges at idle, and dies when i take my foot off the gas.
it stalls but starts back up
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
5 speed.
stock engine, etc. no work has been done under the hood.
177K

seems to be a wet-weather problem also. the previous owner told me it died in the rain and ran like shit, one time.

its not plugs and wires.
 

·
Registered
Joined
·
4,659 Posts
Could be a vacuum issue, start the car and let it idle, And spray some brake clean all around the intake manifold and brake booster and see if the car idles funny after you spray it, if it does; you have a vacuum leak.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
its not a vacuum leak
ive gone over all the obvious stuff. i work as an auto mechanic, but my scanner at work cant read data on my car. this seems like an electrical problem
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
ok a little more info
definitely no vac leaks
egr is working, closed
and it runs pretty well as long as the gas pedal is down, over 2500 rpms
anything?
 

·
Registered
Joined
·
1,748 Posts
Vacuum Leak

Distributor Cap and rotor (Especially if it is a "when wet " problem)
 

·
Registered
Joined
·
1,748 Posts
that will do it...
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
so it idles fine, but it stumbles and hesitates whenever im coasting, or on light throttle. pops pretty badly from the exhaust as well. sensors seem to be working properly, and the condition comes and goes. im leaning towards a bad pcm. anyone have any helpful information or feedback?
 
1 - 10 of 10 Posts
Top