Nissan 240SX Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
It's been a while since ive been here, hope everyone is doing ok. Anyways, I recently swapped an sr20 into another one of my s13's, im using a cody ace adapter bracket for my s13 compressor, before I had the sr20 in the car, I used to be able to activate the comp clutch by the ac button like you should. It just didn't do anything cause at the time I had no bracket or belt. Now that I swapped the sr20 in I re-wired in the command signal from the ecu to the dash interface connector. Everything is connected, pressures are enough, but yet when I go to turn the a/c on the car doesn't idle up and the clutch doesn't kick on. I have tried so hard to make this work and posting here is my last ditch effort before I rip the freakin compressor out and throw it into the woods.
 

·
Registered
Joined
·
20 Posts
Have you managed to fix it?
The most common causes of broken air conditioning are leaks or compressor issues. If your air is blowing cool but not cold, the problem could be a clogged filter, cooling fan problem, radiator trouble, or it could simply be that you need to recharge your AC.
 

·
Registered
Joined
·
1 Posts
I also got into such cases and tried to solve the problem myself, but it only worsened. Then I went to the car repair shop, but they couldn't solve my problem with the air conditioner. Although I spent a lot of time trying to fix it, I thought it would be better to buy a new one already. Experts from the service claimed that I damaged the compressor due to self-repair, and now a complete replacement is needed. But fortunately for me, I came across a company that deals with these issues. Guys from airconservicingsingapore.com served me the best possible way and helped me with a problem that I could not solve for a long time. If you have any problems with the air conditioner, then I'm sure they can help you.
 
1 - 6 of 6 Posts
Top