Nissan 240SX Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,574 Posts
Discussion Starter #1
Weird things have started happening to my 240. Sitting at idle if you try to blip the throttle the RPM drops a few hundred and it kinda bogs....meaning it wont rev for a second and then it will rev hard. Its feels like the engine is choking also parking the RPM drops ALOT and I almost have to ride the clutch just to park. Also if the car stalls out after driving for a bit it will not start up again until after it sits for a couple minutes. It cranks and cranks but doesn't turn over. I got it to turn over this morning by pumpin the gas....weird any suggestions? Im thinking either CAT or distributer.
 

·
Registered
Joined
·
912 Posts
My car bogs a little too. I'd check sensors (don't know which ones, maybe the MAF) and the fuel filter. Its a start...
 

·
Registered
Joined
·
261 Posts
check the vacuum tubes, iav, and egr. I removed most of that stuff, and my car idles a lot better now.
 

·
Registered
Joined
·
1,574 Posts
Discussion Starter #6
Yeah I checked all the VAC lines and everything seems to be good. When she is cold she will start up fine and everything is alright until she gets up to operating temps. Also every once in awhile I get alot of smoke comming out of the tailpipe. I am leaning more towards the MAF, throttle position sensor and possibly the distributor. I had thought about the fuel system too, fuel filter needs to be changed but I don't know why it would be that because it seems like it's getting enough pressure because she does run and everything is alright past like 1500 RPM.
 

·
Registered
Joined
·
2 Posts
Yeah I checked all the VAC lines and everything seems to be good. When she is cold she will start up fine and everything is alright until she gets up to operating temps. Also every once in awhile I get alot of smoke comming out of the tailpipe. I am leaning more towards the MAF, throttle position sensor and possibly the distributor. I had thought about the fuel system too, fuel filter needs to be changed but I don't know why it would be that because it seems like it's getting enough pressure because she does run and everything is alright past like 1500 RPM.
 
1 - 8 of 8 Posts
Top