Nissan 240SX Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
286 Posts
Discussion Starter #1
Its being towed to a friends house. I'm on my blackberry. Tell me whas wrong. It didn't studder, it just died. It cranks, doesn't start, I don't ear fuel pump, where's the main relay? Please help...
 

·
Registered
Joined
·
23 Posts
the inside green relay on the passanger side relay box next to the blue or grey relay is the fuel pump relay.... when ignition is turned on have someone listen to see if it clicks if it does its fine... check voltage on the white and purple wire at the fuel pump plug in the trunk to see if its even getting power when your fuel pump goes out it dont studder sometimes.... friends went out two days ago down the road from his house and it just died... pulled it back to his house changed it and bam runs fine
 

·
Registered
Joined
·
286 Posts
Discussion Starter #3
Where's the main relay? I think it might be that. Abd the fuel pump relay in next to the battery or inside the car. Thanks for the help tho.
 

·
GnarKiller
Joined
·
5,118 Posts
Relay is located in the Fuse /Relay box on the right wheelwell just next to the battery. It is labeled "egi pump". EGI apperently stands for "you'll never figure out what this means", since it isn't referenced anywhere.

Woot for blackberrys. Mine hates the forums because there is so much shit going on.
 

·
Registered
Joined
·
286 Posts
Discussion Starter #5
Well, that looks fine, and I threw some starting fluid in there, and it wanted to start, but nothin. So I'm getting a spark, but I have no fuel. Relay looks good, but where's the main relay at and what does it look like.
 

·
Registered
Joined
·
286 Posts
Discussion Starter #6
please help ive searched and googled but i got nothin. is there a 'main relay' somewhere under the dash or something?
 

·
Registered
Joined
·
1,164 Posts
I didn't know S13s have main relays. Did you actually check the fuel pump? If memory serves correct if the main relay does go on a car then there is a no fuel/no spark condition, meaning you'd have neither.
 

·
Registered
Joined
·
286 Posts
Discussion Starter #9
If my fuses are all good and i cant hear my fuel pump prime, does that mean my fuel pump isnt working? So im guessing there is no 'main relay' like honduhs right?
 

·
Registered
Joined
·
10,717 Posts
i think its the ignition switch where all the relays are in the single cam its two away from the abs i dont know if its the same for you. this happend to me once at the corner of my street
 

·
Registered
Joined
·
10,717 Posts
btw clean dash. you need to lower it. and how much did it cost you to fix the body damage?
 

·
Registered
Joined
·
286 Posts
Discussion Starter #12
Alright. I check the volts on my fuel pump, and I got nothing, then I tested the fuse, and got a good reading. The fuel pump never come onoe hums or anything, so I'm thinkin that I need a new fuel pump. We'll see what happens soon. Where can I buy an oem fuel pump anyway? Local stored don't dtock it and it gonna be a week till rthey do. Any good sites? Thanks for the help guys.
 

·
Registered
Joined
·
1,748 Posts
Alright. I check the volts on my fuel pump, and I got nothing, then I tested the fuse, and got a good reading.
You had the key "on", right?

On the correct connector pins?

Any chance you looked at the FSM?

I don't know if you have a DOHC or SOHC, but the fuel pump circuit is the same

The fuel pump never come onoe hums or anything, so I'm thinkin that I need a new fuel pump. We'll see what happens soon.
If you do not hear the pump prime, and you are not getting power back there, it isn't the pump...

I've never heard of a 240SX fuel pump dieing instantly.. they usually head south slowly...


Where can I buy an oem fuel pump anyway? Local stored don't dtock it and it gonna be a week till rthey do. Any good sites? Thanks for the help guys.
If you need to replace the fuel pump, drop in a Walbro.... same price or cheaper than OEM...
 
1 - 14 of 14 Posts
Top