Nissan 240SX Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
I got a check engine light after installing an Injen Intake. What's the fix for this? I used my OBD Scanner and 0443 code came out (IE EVAP Purge Valve Failure). This is the reason my car couldnt pass smog today! Is there a fix for this?? I checked all my hoses, and they're all secure. I already unplugged the (-) and reset the ECU. Even after that, the CEL still came on. I loosened my gas cap to let some gas pressure out, and nothing came out, so I know the EVAP Purge Valve is still working. What's going on?!?
 

·
Registered
Joined
·
5,783 Posts
its been a while since i installed one of those. probably two years. its probably just a coincidence that it happend when u installed the intake. i heard somewhere that replacing your gas cap can solve some EVAP errors.
 

·
Registered
Joined
·
42 Posts
purge valve

I would guess that you need a purge valve on the canister. Nissan put them in a bad spot behind the rear wheel. They get all rusty and stick. If you are lucky you could replace the valve without having to buy a new charcoal canister.
 

·
Registered
Joined
·
3,751 Posts
most evap codes come from having the gas cap off or leak from the cap.
 

·
Registered
Joined
·
57 Posts
Discussion Starter #6
Yea. I just changed gas caps yesterday. However, before I did that, I put a little Rubber O-Ring around the PVC Valve because it was loose. I could then fill up my gas tank without it stopping every 10-15 seconds. No more check engine light so far for 30 miles. Hopefully it'll stay off!
 

·
Registered
Joined
·
5,783 Posts
awesome....after i saw your post i did a little search because i was curious and its one of the few topics on here that hasnt been discussed 5 bajillion times. the gas cap thing was the only thing i could find. glad it was helpful
 

·
Registered
Joined
·
1,791 Posts
hehe, i need to fix my gas tank filler pine, it's not actually attached to the car, so it wiggles around about an inch and i have to hold the pump filler not all the way up for it to fill without stopping.

oh well. the car makes up for that pain with boost :)
 

·
Registered
Joined
·
1,028 Posts
a bad gas cap would come up as a evap gross leak. there is no way that your intake is really the cause of this. red97 kouki was right, nissan puts the evap components in a really bad place so they fail. living in usa and being horribly biased on emissions, your state is gonna make you fix it (more money for nissan) - makes sense from a comapny stand point. i would replace it with a used one and try that out because our parts can definatley be expensive. unfortunatley i dont have access to assist right now but i can tell you that the code probably came because there was insufficient voltage to the component or the ecu didnt see that the valve moved. if you have the full service manual check for power at the valve and good ground, also check for a voltage drop on the wire that feeds power to the evap purge valve, also make sure the ecu is sending out the signal to open the valve. good luck! (wiring is the easyest and most pain in the ass part of being a mechanic)
 
1 - 10 of 10 Posts
Top