Nissan 240SX Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1
alright guys ive got a problem with my clutch, it started last night when i was in the middle of a race with a spec v... well anyway, the clutch doesnt feel soft or anything but when i put it in first and let up on the clutch it engages pretty much as soon as i start letting up and the car shakes pretty badly. i also have a sqeeky sound when i release the clutch and it starts to engage the flywheel again. do you guys think i need a new clutch or would it be something else. i am personally leaning towards a new clutch i bled the system but it didnt do anything.

thanks for the help
 

·
Registered
Joined
·
423 Posts
squeaky sound could be a few things, might be a pilot bushing, throw out bearing or a broken pressure plate. First thing, I would do would be pull the inspection plate and see if any shrapnel is in the housing. Realitively easy to do, but obviously something is not right, so you might be best off pulling the trans and replacing the clutch.
 

·
Registered
Joined
·
2 Posts
sounds similair, like its trying to grab but slips alot and you got to position the clutch pedal to actually move the car a bit.yeah get a new clutch kit when that happened to me my mechanic pulled my tranny removed the pressure plate
freakin clutch was falling apart, springs and pads where loose, pressure plate hammerd.throw back bearing must replace.
 

·
Registered
Joined
·
88 Posts
awesome i thought that big ass hole in my trans was supposed to be covered up with a "inspection plate" fml that means new trans all together for me.ive been driving that bitch for months with no plate.
 
1 - 6 of 6 Posts
Top