Nissan 240SX Forums banner
1 - 9 of 9 Posts

· Registered
Joined
·
77 Posts
Discussion Starter · #1 ·
Help,
I have had no problems with my car until today. When I am idling in a parking lot or at a stop sign the car will just die. I found a temparary fix, by just holding down the gas a little, but if I dont do it manually the engine will just kill itself. and when the engine turns off i lose power steering so it is dangerous. Anyone know what could be wrong and or how to fix it thanks.
i have a ka24de

thanks,
JoN
 

· Registered
Joined
·
261 Posts
I'd check the MAF to see if that looks good. Can you tell if its running rich/lean?
Hows the cars condition otherwise? Recent tune up?
 

· Registered
Joined
·
158 Posts
Hay i think i got the same problem as you ...unfortunatly my car is having cosmetic work so i cant fix the mechanical end..... but i think and so do others i know thinking its a timing or a vacume problem...when ur driving and u just let go of the gas and drop out of gear real quick does it shut off as well..... also when u start the car after its warmed up will it shut off or idle real low
 

· Registered
Joined
·
77 Posts
Discussion Starter · #4 ·
driftmotoring said:
Hay i think i got the same problem as you ...unfortunatly my car is having cosmetic work so i cant fix the mechanical end..... but i think and so do others i know thinking its a timing or a vacume problem...when ur driving and u just let go of the gas and drop out of gear real quick does it shut off as well..... also when u start the car after its warmed up will it shut off or idle real low
do you know how i can check if this is it? like checking the hoses or anything?

thanks,
jon
 

· Registered
Joined
·
169 Posts
Hey,
I have the same problem all though it hasnt been doing it lately....but anyway yes there is an answer. If you go to 240sx.org and click on the faqs sec there is a write up called Idle irregularity. Click on that and it tells how the problem is with the IAA valve. It says you may wish to clean all the ground wire connections for the car's ignition and injection system. I think that wires might be loose and its causing the idle to drop and die. Im looking into buying some new ground wires to fix the problem. Here is a link to a HKS grounding kit.

http://www.modacar.com/products/Nissan/240SX/GROUNDK/

Iv seen cheaper kits out there so you have to look. Im pretty sure this would fix the problem but before you go out and buy anything check all the connections and make sure they are on tight and see if that helps first.
 

· Registered
Joined
·
77 Posts
Discussion Starter · #6 ·
k i will see if that is it:
Iaa Valve Adjustment
The IAA valve assembly is located on the passenger side of the motor down
below and behind the intake manifold. It's about 8" from the firewall.
According to the Nissan shop manual, to adjust the IAA valve, disconnect
the throttle sensor harness connector with the motor shut off. Now with the
engine idling in neutral, adjust the IAA for an idle speed of 650 RPM. With
the motor shut off, reconnect the harness connector. Now with the motor
idling, you should have an idle speed of 700 RPM. If you can't get the
proper idle speed, the AAC valve may be defective as It's the one that
receives signals from the ECU. The AAC bolts on to the IAA.

Thanks,
jon
 

· Registered
Joined
·
524 Posts
if that's not it... try check if it's the mafs... try unpluging the mafs plug and start the car.. see if it idles and not die ... then plug it back in and start it again to see if it idles fine and don't die on you, if so .. it should be the mafs...
 

· Registered
Joined
·
158 Posts
Well that makes almost no sense to me...for instance my cars battery terminal wasnt that tight i know for sure... but it did kinda fit lol....dont ask...but anyways if it was a electrical problem makes no sense on why it would do it at ONLY idle.... to be honest your best bet is to hook the car up to a reader and see what code pops up.... then again its a JDM motor might not work...but anyways... yah so ur having the same problem as me???? did it just grow or just one day turn the car and act like that cause thats how mine was...

honestly thinking that means the idle switch is bad...that could be the case but its odd cause if my car is warm and i rev it then let go standing still it runs down to 100 rpm then back up to about 800 or so....I am so dam lost lol.... Well i get it back in a week I HOPE...and as soon as i figure it out i let u all know
 
1 - 9 of 9 Posts
Top