Nissan 240SX Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
ok well ive searched and nothing came up that i wanted.i have a 90 ka24e that one night after putting gas in started running horrible. i put new plugs, wires, cap, and rotor. didnt fix it. i pull off #2 wire and there is no change. so i figured it was bad gas. i drained it and it had alot of water in it. i cleaned the tank threw in 2 gallons of 93 octane. installed new fuel filter fired it up and again no change. so i figured maybe #2 injector was clogged since there was alot of dirt in the tank. i swapped out the injector with a different one. again no change. i did a compression test and it has above 150 across the board. im lost the only thing i can think of is that some how the ecu is messed up. ive read the it could be the egr stuck open or a vaccum leak. but if it was why would only cylinder 2 have a miss fire. i can unplug the injector when its running and no change same when i pull the plug wire. any help would be greatly helpful.
 

·
Registered
Joined
·
19 Posts
if you did all of that and nothing changed then check your Intake and Exhaust valves... that tends to happen with the Ka24e...
 

·
Registered
Joined
·
19 Posts
if your valves are clogged you won't get fuel... mix octane with your gas and if that doesn't work you'll have to replace them...
 

·
Registered
Joined
·
1,748 Posts
Check your fuel pressure..

you could have plugged up the sock on the fuel pump...

it isn't the ECU from bad gas... unless you poured it all over the ecu...

you didn't... did you?
 

·
Registered
Joined
·
41 Posts
Discussion Starter #7
ok well im getting a ecu for testing just maybe the ecu is shot for sum odd reason. i kno a auto ecu will run a 5spd but will a 5spd ecu run a auto car?
 

·
Registered
Joined
·
1,748 Posts
it should, at least for trouble shooting purposes... probably it will run fine too...

your idle could be low in Drive at a stop though...
 

·
Registered
Joined
·
41 Posts
Discussion Starter #9
yea. ok thanks i guess this wil help when i do my 5spd swap even tho it dont need to change the ecu.
 

·
Registered
Joined
·
71 Posts
i had the same problem, but with my 92 ka24de though.. my #3 cylinder didnt change when i pulled the wire too.. did a full tune up and all, checked for vacuum leaks and couldnt find nothing.. then i checked the injectors and the clip on #3 cylinder was loose.. got it tightened up and it runs perfect now.. id check to see if yer injectors are pulsing.. good luck..
 

·
Registered
Joined
·
41 Posts
Discussion Starter #11
injectors are pulsing. i swapped out the ecu and still has the same problem. i think there is something in the fuel system. im going to run an intake cleaner machine throw it see if that helps
 

·
Registered
Joined
·
483 Posts
SEAFOAM it! Seafoam works wonders and is great for pissing off neighbors. put one can in the gas and run another through the intake. It can't hurt.
 

·
Registered
Joined
·
483 Posts
grab a spare plug and hook it up to the wire for the missing cylinder and see if it sparks. Just another thought. You may have also swapped in another faulty injector. If you have fuel, compression, and spark, the engine has no choice but to run.
 

·
Registered
Joined
·
56 Posts
Check the injector. Do you know how to measure resistance? Get a multimeter and unplug the injector from the connector. Put the two ends of the multimeter (in ohm mode) onto the two different prongs. The spec for the injectors is 12ohms. If you're above that than you may have a bad injector, such is my problem at the moment. My #1 fuel injector isn't firing and its resitance is 120, and yes thats right. Somehow the coil inside the injector managed to get f'ed up.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #15
ive seafoamed it twice. i hooked at machine up to the injector clipe and the machine lit up everytime it fired. if it has too much power how do you fix it??
 

·
Registered
Joined
·
56 Posts
There is actually a TSB for Nissan saying that on pintle-less injectors (such as the kind in some ka's according to it) you shouldn't use fuel injector cleaners as they may destroy the injector. Did you check the injector itself yet?
 

·
Registered
Joined
·
41 Posts
Discussion Starter #17
well figured it out today. the egr was stuck all the way open, pulled it off and got it free then pluged the vac. line so that it wont happen again. o yea no more egr!! lol.
 
1 - 17 of 17 Posts
Top