Nissan 240SX Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi. I just bought a 93 240 with a RB20 swap in it. I am a newbie to RB's, but not to 240s. I previously owned a s13 coupe with an SR.

I dont know crap about this motor besides the basics. Heres a pic of mine:


I was told that I was missing some vaccum lines, but they didnt elaborate where. It seems to run alright, has a boost leak so Im going to replace all the intercooler piping.

Also you have to squirt some gas into on of the vacuum hoses to get it to start first thing when the motors cold. Know what might cause this problem?

Also can anybody tell me somethings I should check/ go over?
 

·
Registered
Joined
·
853 Posts
welcome rb brother..

an oil catch can would be very helpful.

and yes getting the bov to recirc should be a top priority(also plug that hose on top of the valve cover).
did the previous owner say where they got the wiring done??

did you change the oil?? it uses a z32 oil filter and 4 and half qts..
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Ha, yes the wiring. I think it was the owner b4 the guy I got it from. Its a GD rats nest near the ECU. Im considering pulling it out and cleaning it up. Just dont want to screw something up and cause any problems.
 

·
Registered
Joined
·
853 Posts
well pulling it. rewrapping it. or even sending it out to be checked(don't want a short or a wire fire) would be a great idea. always beware of a shoddy wiring job..
 

·
Registered
Joined
·
31 Posts
Hi. I just bought a 93 240 with a RB20 swap in it. I am a newbie to RB's, but not to 240s. I previously owned a s13 coupe with an SR.

I dont know crap about this motor besides the basics. Heres a pic of mine:


I was told that I was missing some vaccum lines, but they didnt elaborate where. It seems to run alright, has a boost leak so Im going to replace all the intercooler piping.

Also you have to squirt some gas into on of the vacuum hoses to get it to start first thing when the motors cold. Know what might cause this problem?

Also can anybody tell me somethings I should check/ go over?
Cold start is controlled by a small valve that sits just under the TB and works in conjunction with the IAC. If you follow the larger air tube off of the IAC that Ts into the intake tube, it's connected to the lower part of that T. If that has been bypassed or is not functional, you will continue to have a cold start problem.

Here's a good site that talks directly about the valve I am talking about. http://www4.wave.co.nz/~lakewood/Skyline/ColdAirReg.htm
 

·
Registered
Joined
·
79 Posts
just beacause it has a boost leak dosent just mean its the intercooler piping. it could be the fact your missing vac lines. it also could be gaskets, your injectors ect. you should leak test your engine before you go replacing things that dont need to be replaced.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
just beacause it has a boost leak dosent just mean its the intercooler piping. it could be the fact your missing vac lines. it also could be gaskets, your injectors ect. you should leak test your engine before you go replacing things that dont need to be replaced.
One of the intercooler pipes has a small hole in it. Thats where the leak is. Plus the pipes are steel, I wanted aluminum.




Hey Gen Pac thanks for the info on the cold start.
 

·
Registered
Joined
·
5,137 Posts
Considering that you still have the stock dump valve mounted, you might want to make sure you are not leaking here. I am not sure why they mounted that Blitz one where they did. You can bolt the Blitz BOV straight to the stock location, if you had the kit with the flange.
 

·
Registered
Joined
·
152 Posts
Welcome to RB.
I suggest you download the FSM and study the vacuum and intercooler lines carefully. Make sure everything is installed as per stock first. Then track down and eliminate the problems once you have learned how the idle and cold start system works. After that, you can pile stuff on. Don't install a catch can unless you know WTF you are doing. You can ruin turbo seals if you mess up your crankcase ventilation with an improper catch can install.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #12 ·
Yeah I need the service manual for the RB(does that come in English?). And I need the wiring diagram for a 93 240.

Usually when I run a catch can I just run a hose from the top of the valve cover and I dont run a return. But I dont know shit. Im a bodyman not a mechanic!
 
1 - 12 of 12 Posts
Top