Nissan 240SX Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1 Posts
Hey everyone! I joined the forums right after getting my first 240 since I was in high school! I just picked her up 3 days ago and am excited to share. It's a 93 with an SR20 which ran me pretty steep but it has a clean body and puts 364hp to the wheels.

Hey everyone! I joined the forums right after
Tire Wheel Land vehicle Vehicle Car

getting my first 240 since I was in high school! I just picked her up 3 days ago and am excited to share. It's a 93 with an SR20 which ran me pretty steep but it has a clean body and puts 364hp to the wheels.
 

·
Administrator
Joined
·
5,179 Posts
Discussion Starter · #3 ·
Hey everyone! I joined the forums right after getting my first 240 since I was in high school! I just picked her up 3 days ago and am excited to share. It's a 93 with an SR20 which ran me pretty steep but it has a clean body and puts 364hp to the wheels.
That thing looks good so far. Welcome to the forum!
 

·
Registered
Joined
·
2 Posts
Hi, coming here because I'm considering the purchase of a particular car. Have had a long time interest in the platform, but have always had others take priority. Maybe it's finally time to get an S-chassis, maybe it isn't. I'd be thankful if you can help me make that decision in my first post.


Sent from my Pixel 5 using Tapatalk
 

·
Administrator
Joined
·
5,179 Posts
Discussion Starter · #5 ·
Hi, coming here because I'm considering the purchase of a particular car. Have had a long time interest in the platform, but have always had others take priority. Maybe it's finally time to get an S-chassis, maybe it isn't. I'd be thankful if you can help me make that decision in my first post.


Sent from my Pixel 5 using Tapatalk
Welcome! The site is lot more slow than it used to be, but there are still some people who check in and should be able to give some advice.
 

·
Registered
Joined
·
2 Posts
What’s up fam, always been on the forums since i bought the 240. Love the turbo build bible that someone did yeaars ago lol. anyways here the whip, bought it a few months ago, was running good until i had some problems ( i believe its the timing) i bought another maf and put in a new maf pigtail because I thought that was the problem. But we believe its the timing since its idling weird. We checked if its a vacuum leak but its not. If y’all have any ideas let me know.
Tire Car Vehicle Wheel Hood
 

Attachments

·
Registered
Joined
·
14 Posts
1 - 12 of 12 Posts
Top