Nissan 240SX Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
I got the timing set right in. The car will fire right up, but it seems to be running rich and studders really bad. I resoldered the MAF wiring. Then I tested the TPS out and it's working fine. I put new plugs in (old ones were fouled in 20 mins) and fired it up... the car sounded like a wrx again. Turns out that the coil in cylinder #2 is barely firing (not even enough to spark the plug). I switched the coil with one from my old redtop and it did the same thing. I then gave it a straight ground, and it got a little stronger, so I gave it a straight power source and again it got a little better, but still not enough to spark the plug! I changed out the ignition harness with the one from my redtop and it didn't help anything either. I also gave the ignitior chip another ground without any luck. The ecu takes care of the pulsing, so why would it be so weak only on that one coil? Could my ignitor be bad? Any ideas?

Thanks,
Jesse
 

·
Registered
Joined
·
101 Posts
one suggestion is check the cas,im not familiar with s14 sr ,try swiching the cas .from what your telling sounds like spark problem maybe ecm not getting strong signal fron cas ,check the ground also on cas.hope this helps.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 · (Edited)
I don't think it is so much a fuel problem as ignition.

It ran alright at first, then the problem started. I was able to take it for a ride and it had a ton of power. I shut it off, wired up some gauges (A/F, autometer water temp, stock tach, stock water temp), then this started. I was able to take it for a ride after the gauges, but had to retime the car, which makes me think it might be the CAS. It is just that one coil running really weak. I switched over everything from my old engine that ran fine. I am using the ignitor and CAS from my old engine, then I switched over a coil and the ignition harness from the other engine to see if it was just that one coil but no luck. Could the CAS cause just the one coil to have such a weak spark that way?
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #5 ·
OK... I tried some more stuff without luck...
-CAS
-Ignitor
-Ignition harness
-Took off the tach signal thinking maybe I wired it to the cylinder #2 ignition signal

I am down to an ECU now. Could the ecu send a very weak signal to the coil and cause it to barely spark? The whole problem is that the 2nd cly's coil isn't firing. After removing the tach wiring, I fired it up and it ran fine for like 3 mins, then went back to not firing on that coil, so I don't think it could have been that wire. Maybe me messing with the ecu fixed it for a min, I dunno. I hate problems like this. I always seem to get stuck with weird problems, lol. My wiring harness is brand new from nissan also, so it shouldn't be that at all. Anybody want a 3cyl s13 for $10?
 
1 - 5 of 5 Posts
Top