Nissan 240SX Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
i recently bought a peak performance racing transmission mount, and installed it. i wasnt sure about this part being the correct mount for my car. it seemed to look very different than the stock mount as well as other upgraded trans mounts ive seen ( i.e. nismo trans mount). but the mount did bolt up exactly, so i went ahead and installed it. during the test dirve after installation, the car shook very bad, and the cockpit noise was unbearable, do any of you have a clue as to what i did wrong, i would really appreciate your feedback, even if it is to call me an idiot for installing it soooo incorrectly, thank you
 

·
Registered
Joined
·
512 Posts
well.. it could be acouple things. the first is to make sure the bolts are all tight.(asuming yuou made sure they were tight to begin with) The second thing is to check and see if the trans, an dthe driveshaft meet in a straightline.. if you know what i'm talking about. the u-joints are ment for angle changes but if it is too severe it coudl throw teh balance of teh drive shaft off.. Just check those small things.. or maybe a bolt loosened or something....
 

·
Registered
Joined
·
512 Posts
umm put the old mount on caus ethe new mount is eitehr wrong, poorly made.. or just plain screwed up. You could jerry rig soemthing. but, that isn't my style
 

·
Registered
Joined
·
3,468 Posts
Is that one the flat bar like mount? If so do you have stiffened front motor mounts? Also usually those don't have a place to mount the downpipe bracket.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #6 ·
ur exactly correct, i dont have new motor mounts, i ordered them and they r coming in but i just installed this cuz it arrived first.
 

·
Registered
Joined
·
501 Posts
My jgy customs banana mount didn't cause that. maybe its too stiff of a material?? there should be a little play i would think.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #9 ·
eh, well i figured it out. well my tranny mount was nice and solid, but over time my old crappy motor mounts wore (i ordered new ones , and they will be here soon) and were sagging a lil. so the tranny was up higher. leaving the tranny at an angle, so the driveshaft was at an angle as well, to drastic to run normally, so the moral of the story is, dont be an idiot like me and put ur motor and tranny mounts in at the same time
 
1 - 9 of 9 Posts
Top